Firmware Downloads Unavailable

Incident Report for myenergi

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 08:35 UTC

Monitoring

We are continuing to monitor for any further issues.
Posted Jan 29, 2026 - 14:58 UTC

Update

We are continuing to monitor for any further issues.
Posted Jan 29, 2026 - 14:57 UTC

Investigating

Firmware downloads are currently unavailable or performing very slowly for all devices except GLO. This does not impact the ability to install previously downloaded firmware.
Posted Jan 29, 2026 - 08:37 UTC
This incident affected: Firmware Updates.