Myaccount Down

Incident Report for myenergi

Resolved

This incident has been resolved.
Posted Jul 11, 2024 - 09:23 UTC

Identified

We have identified an issue with Myaccount causing the page not to load.
Posted Jul 11, 2024 - 09:04 UTC
This incident affected: Myaccount.